classifyPointContainment Method
Determines whether the given points fall inside or outside this set of ClipShapes. If any set is defined by masking planes, checks the mask planes only, provided that ignoreMasks is false. Otherwise, checks the _clipPlanes member.
classifyPointContainment(points: Point3d[], ignoreMasks: boolean = false): ClipPlaneContainment
Parameter | Type | Description |
---|---|---|
points | Point3d[] | |
ignoreMasks | boolean |
Returns - ClipPlaneContainment
Defined in
- clipping/ClipVector.ts Line 334
Last Updated: 20 June, 2023