setRotationAboutPoint Method
Set the rotation of this ViewState to the supplied rotation, by rotating it about a point.
setRotationAboutPoint(rotation: Matrix3d, point?: Point3d): void
Parameter | Type | Description |
---|---|---|
rotation | Matrix3d | The new rotation matrix for this ViewState. |
point | Point3d | The point to rotate about. If undefined, use the ViewState.getTargetPoint. |
Returns - void
Defined in
- core/frontend/src/ViewState.ts Line 1113
Last Updated: 20 June, 2023