zoomToElements Method
Zoom the view to a show the tightest box around a given set of elements. Optionally, change view rotation.
zoomToElements(ids: Id64Arg, options?: ViewChangeOptions & MarginOptions & ZoomToOptions): Promise<void>
Parameter | Type | Description |
---|---|---|
ids | Id64Arg | the element id(s) to include. Will zoom to the union of the placements. |
options | ViewChangeOptions & MarginOptions & ZoomToOptions | options that control how the view change works and whether to change view rotation. |
Returns - Promise<void>
Defined in
- core/frontend/src/Viewport.ts Line 2061
Last Updated: 20 June, 2023