ViewChangeOptions Interface
Options that control how operations that change a viewport behave.
extensions
Extends
Inherited methods
Name | Inherited from | Description |
---|---|---|
animationFinishedCallback(didComplete: boolean): void Optional | ViewAnimationOptions | Invoked when the animator is finished. |
onExtentsError(status: ViewStatus): ViewStatus Optional | OnViewExtentsError | Function to be called when the extents are adjusted due to a limits error (view too larger or too small) |
Properties
Name | Type | Description | |
---|---|---|---|
animateFrustumChange | undefined | boolean | Whether the change should be animated or not. | |
globalAlignment | undefined | GlobalAlignmentOptions | If defined the controls how the view will be aligned with the globe | |
noSaveInUndo | undefined | boolean | Whether to save the result of this change into the view undo stack. |
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
animationTime | undefined | number | ViewAnimationOptions | Amount of time for animation, in milliseconds. |
cancelOnAbort | undefined | boolean | ViewAnimationOptions | if animation is aborted, don't move to end, leave at current point instead. |
easingFunction | undefined | EasingFunction | ViewAnimationOptions | easing function for animation. |
Defined in
Last Updated: 20 June, 2023