pickDepthPoint Method
Find a point on geometry visible in this Viewport, within a radius of supplied pick point. If no geometry is selected, return the point projected to the most appropriate reference plane.
pickDepthPoint(pickPoint: Point3d, radius?: number, options?: DepthPointOptions): { plane: Plane3dByOriginAndUnitNormal, source: DepthPointSource, sourceId?: string }
note The result plane normal is valid when the source is not geometry or a reality model.
Parameter | Type | Description |
---|---|---|
pickPoint | Point3d | Point to search about, in world coordinates |
radius | number | Radius, in pixels, of the circular area to search. |
options | DepthPointOptions | Optional settings to control what can be selected. |
Returns - { plane: Plane3dByOriginAndUnitNormal, source: DepthPointSource, sourceId?: string }
A plane with origin from closest geometry point or reference plane projection and the source of the depth point.
Defined in
- core/frontend/src/Viewport.ts Line 3131
Last Updated: 20 June, 2023