DepthPointSource Enumeration
Source of depth point returned by Viewport.pickDepthPoint.
Members
Name |
Value |
Description |
Geometry |
0 |
Depth point from geometry within specified radius of pick point |
Model |
1 |
Depth point from reality model within specified radius of pick point |
BackgroundMap |
2 |
Depth point from ray projection to background map plane |
GroundPlane |
3 |
Depth point from ray projection to ground plane |
Grid |
4 |
Depth point from ray projection to grid plane |
ACS |
5 |
Depth point from ray projection to acs plane |
TargetPoint |
6 |
Depth point from plane passing through view target point |
Map |
7 |
Depth point from map/terrain within specified radius of pick point |
Defined in
Last Updated:
20 June, 2023