overrideElementHit MethodOptional
If the Decorator.decorate method created pickable graphics using a persistent element id instead of a transient id, return true if the Decorator wants the opportunity to override the default persistent element behavior for the supplied HitDetail.
- Replace or augment the element's tooltip by implementing Decorator.getDecorationToolTip.
- Override the element's snap geometry by implementing Decorator.getDecorationGeometry.
- Handle button events as decorator events by implementing Decorator.onDecorationButtonEvent.
overrideElementHit(hit: HitDetail): boolean
Parameter | Type | Description |
---|---|---|
hit | HitDetail | The HitDetail of the currently selected persistent element or pickable graphics using a persistent element id. |
Returns - boolean
true if this Decorator wants to override the default persistent element behavior.
Last Updated: 20 June, 2023