onDecorationButtonEvent MethodOptional
If Decorator.testDecorationHit or Decorator.overrideElementHit returned true, implement this method to handle a button event for this Decorator.
onDecorationButtonEvent(hit: HitDetail, ev: BeButtonEvent): Promise<EventHandled>
Parameter | Type | Description |
---|---|---|
hit | HitDetail | The HitDetail about the decoration that was picked. |
ev | BeButtonEvent | The BeButtonEvent that identified this decoration. |
Returns - Promise<EventHandled>
A Promise that resolves to Yes if event completely handled by decoration and event should not be processed by the calling tool.
Last Updated: 20 June, 2023