getDecorationToolTip MethodOptional
If Decorator.testDecorationHit or Decorator.overrideElementHit returned true, implement this method to return the tooltip message for this Decorator.
getDecorationToolTip(hit: HitDetail): Promise<string | HTMLElement>
Parameter | Type | Description |
---|---|---|
hit | HitDetail | The HitDetail about the decoration that was picked. |
Returns - Promise<string | HTMLElement>
A promise with the HTMLElement or string (that may contain HTML) with the tooltip message.
Last Updated: 20 June, 2023