Cluster<T extends Marker> Class
A cluster of one or more Markers that overlap one another in the view. The cluster's screen position is taken from its first entry. Clusters also have a Marker themselves, that represents the whole group. The cluster marker isn't created until all entries have been added.
extensions
Methods
Name | Description | |
---|---|---|
constructor<T extends Marker<T>>(markers: T[]): Cluster<T> | ||
getClusterLocation(): Point3d | Gets the location for the cluster |
Properties
Name | Type | Description | |
---|---|---|---|
clusterMarker | undefined | Marker | ||
markers Readonly | T[] | ||
position Accessor ReadOnly | Point3d |
Defined in
- core/frontend/src/Marker.ts Line 325
Last Updated: 20 June, 2023