EditManipulator.HandleUtils Class
Utility methods for creating control handles and other decorations.
Methods
Name | Description | |
---|---|---|
constructor(): EditManipulator.HandleUtils | ||
adjustForBackgroundColor(color: ColorDef, vp: Viewport): ColorDef Static | Adjust input color for contrast against view background. | |
getArrowShape(baseStart: number = 0.0, baseWidth: number = 0.15, tipStart: number = 0.55, tipEnd: number = 1.0, tipWidth: number = 0.3, flangeStart: number = tipStart, flangeWidth: number = baseWidth): Point3d[] Static | Return array of shape points representing a unit arrow in xy plane pointing in positive x direction. | |
getArrowTransform(vp: Viewport, base: Point3d, direction: Vector3d, sizeInches: number): undefined | Transform Static | Compute a transform that will try to orient a 2d shape (like an arrow) to face the camera. |
Defined in
Last Updated: 20 June, 2023