BeWheelEventProps Interface
Properties for constructing a BeWheelEvent
extensions
Extends
Implemented by
Properties
Name | Type | Description | |
---|---|---|---|
time | undefined | number | ||
wheelDelta | undefined | number |
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
button | undefined | BeButton | BeButtonEventProps | The mouse button for this event. |
coordsFrom | undefined | CoordSource | BeButtonEventProps | How the coordinate values were generated (either from an action by the user or from a program.) |
inputSource | undefined | InputSource | BeButtonEventProps | Whether this event came from a pointing device (e.g. |
isDoubleClick | undefined | boolean | BeButtonEventProps | If true, this is the second down in a rapid double-click of the same button. |
isDown | undefined | boolean | BeButtonEventProps | If true, this event was generated from a mouse-down transition, false from a button-up transition. |
isDragging | undefined | boolean | BeButtonEventProps | If true, this event was created by pressing, holding, and then moving a mouse button. |
keyModifiers | undefined | BeModifierKeys | BeButtonEventProps | |
point | undefined | Point3d | BeButtonEventProps | The point for this event, in world coordinates. |
rawPoint | undefined | Point3d | BeButtonEventProps | The raw (unadjusted) point for this event, in world coordinates. |
viewPoint | undefined | Point3d | BeButtonEventProps | The point, in screen coordinates for this event. |
viewport | undefined | ScreenViewport | BeButtonEventProps | The ScreenViewport for the BeButtonEvent. |
Defined in
- core/frontend/src/tools/Tool.ts Line 326
Last Updated: 20 June, 2023