BeButtonEventProps Interface
Properties for constructing a BeButtonEvent
extensions
Implemented by
Properties
Name | Type | Description | |
---|---|---|---|
button | undefined | BeButton | The mouse button for this event. | |
coordsFrom | undefined | CoordSource | How the coordinate values were generated (either from an action by the user or from a program.) | |
inputSource | undefined | InputSource | Whether this event came from a pointing device (e.g. | |
isDoubleClick | undefined | boolean | If true, this is the second down in a rapid double-click of the same button. | |
isDown | undefined | boolean | If true, this event was generated from a mouse-down transition, false from a button-up transition. | |
isDragging | undefined | boolean | If true, this event was created by pressing, holding, and then moving a mouse button. | |
keyModifiers | undefined | BeModifierKeys | ||
point | undefined | Point3d | The point for this event, in world coordinates. | |
rawPoint | undefined | Point3d | The raw (unadjusted) point for this event, in world coordinates. | |
viewPoint | undefined | Point3d | The point, in screen coordinates for this event. | |
viewport | undefined | ScreenViewport | The ScreenViewport for the BeButtonEvent. |
Defined in
- core/frontend/src/tools/Tool.ts Line 116
Last Updated: 20 June, 2023