BeButtonState Class
extensions
Methods
Name | Description | |
---|---|---|
constructor(): BeButtonState | ||
init(downUorPt: Point3d, downRawPt: Point3d, downTime: number, isDown: boolean, isDoubleClick: boolean, isDragging: boolean, source: InputSource): void |
Properties
Name | Type | Description | |
---|---|---|---|
downRawPt Accessor | Point3d | ||
downTime | number | ||
downUorPt Accessor | Point3d | ||
inputSource | InputSource | ||
isDoubleClick | boolean | ||
isDown | boolean | ||
isDragging | boolean |
Defined in
- core/frontend/src/tools/Tool.ts Line 87
Last Updated: 20 June, 2023