TileTreeSupplier Interface
Interface adopted by an object which can supply a TileTree for rendering. A supplier can supply any number of tile trees; the only requirement is that each tile tree has a unique identifier within the context of the supplier and a single IModelConnection. The identifier can be any type, as only the supplier needs to be able to interpret it. However, it is essential that the identifier is treated as immutable, because it is used as a lookup key in a sorted collection - changes to its properties may affect comparison and therefore sorting order.
see Tiles.getTileTreeOwner to obtain a tile tree from a supplier.
extensions
Methods
Name | Description | |
---|---|---|
addModelsAnimatedByScript(modelIds: Set<string>, scriptSourceId: string, trees: Iterable<{ id: any, owner: TileTreeOwner }>): void Optional | Given the set of trees belonging to this supplier, add the modelIds associated with any trees that are animated by | |
addSpatialModels(modelIds: Set<string>, trees: Iterable<{ id: any, owner: TileTreeOwner }>): void Optional | Given the set of trees belonging to this supplier, add the modelIds associated with any trees representing spatial models. | |
compareTileTreeIds(lhs: any, rhs: any): number | Compare two tree Ids returning a negative number if lhs < rhs, a positive number if lhs > rhs, or 0 if the Ids are equivalent. |
|
createTileTree(id: any, iModel: IModelConnection): Promise<undefined | TileTree> | Produce the TileTree corresponding to the specified tree Id. |
Properties
Name | Type | Description | |
---|---|---|---|
isEcefDependent Readonly | undefined | "true" | true if this supplier is dependent upon the IModelConnection's EcefLocation. |
Defined in
Last Updated: 20 June, 2023