ViewportGraphicBuilderOptions Interface
Options for creating a GraphicBuilder to produce a RenderGraphic to be displayed in a specific Viewport. The level of detail of the graphic will be computed from the position of its geometry within the viewport's Frustum. Default values for GraphicBuilderOptions.wantNormals and GraphicBuilderOptions.generateEdges will be determined by the viewport's ViewFlags. The GraphicBuilder.iModel will be set to the viewport's IModelConnection.
extensions
Extends
Properties
Name | Type | Description | |
---|---|---|---|
applyAspectRatioSkew | undefined | boolean | If true, ViewState.getAspectRatioSkew will be taken into account when computing the level of detail for the produced graphics. | |
computeChordTolerance | undefined | undefined | ||
iModel | undefined | undefined | ||
viewport | Viewport | The viewport in which the resultant RenderGraphic is to be drawn. |
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
generateEdges | undefined | boolean | GraphicBuilderOptions | Controls whether edges are generated for surfaces. |
pickable | undefined | PickableGraphicOptions | GraphicBuilderOptions | If the graphic is to be pickable, specifies the pickable Id and other options. |
placement | undefined | Transform | GraphicBuilderOptions | The local-to-world transform in which the builder's geometry is to be defined - by default, an identity transform. |
preserveOrder | undefined | boolean | GraphicBuilderOptions | If true, the order in which geometry is added to the builder is preserved. |
type | GraphicType | GraphicBuilderOptions | The type of graphic to produce. |
viewIndependentOrigin | undefined | Point3d | GraphicBuilderOptions | If defined, specifies a point about which the graphic will rotate such that it always faces the viewer. |
wantNormals | undefined | boolean | GraphicBuilderOptions | Controls whether normals are generated for surfaces. |
Defined in
Last Updated: 20 June, 2023