Scene Class
Holds a collection of objects comprising the scene to be drawn by a Viewport's.
see SceneContext for the context in which the scene is created.
extensions
Methods
Name | Description | |
---|---|---|
constructor(): Scene |
Properties
Name | Type | Description | |
---|---|---|---|
background Readonly | RenderGraphic[] | Graphics to be drawn in the background behind all other graphics. | |
foreground Readonly | RenderGraphic[] | Graphics to be drawn as a "normal" part of the scene - that is, with depth. | |
overlay Readonly | RenderGraphic[] | Graphics to be overlaid atop all other graphics. |
Defined in
Last Updated: 20 June, 2023