createBranch Method
Create a RenderGraphic which groups a set of graphics into a node in a scene graph, applying to each a transform and optional clip volume and symbology overrides.
createBranch(branch: GraphicBranch, location: Transform): RenderGraphic
Parameter | Type | Description |
---|---|---|
branch | GraphicBranch | Contains the group of graphics and the symbology overrides. |
location | Transform | the local-to-world transform applied to the grouped graphics. |
Returns - RenderGraphic
A RenderGraphic suitable for drawing the scene graph node within this context's Viewport.
Defined in
- core/frontend/src/ViewContext.ts Line 92
Last Updated: 20 June, 2023