MeshParams Class
Describes mesh geometry to be submitted to the rendering system. A mesh consists of a surface and its edges, which may include any combination of silhouettes, polylines, and single segments. The surface and edges all refer to the same vertex table.
Methods
Name | Description | |
---|---|---|
constructor(vertices: , surface: , edges?: EdgeParams, isPlanar?: boolean, auxChannels?: ): MeshParams | Directly construct a MeshParams. | |
create(args: MeshArgs): MeshParams Static | Construct from a MeshArgs. |
Properties
Name | Type | Description | |
---|---|---|---|
auxChannels Readonly | undefined | | ||
edges | undefined | EdgeParams | ||
isPlanar Readonly | boolean | ||
surface Readonly | |||
vertices Readonly |
Defined in
Last Updated: 20 June, 2023