MeshArgs Interface
Properties
Name | Type | Description | |
---|---|---|---|
auxChannels | undefined | | ||
colors | ColorIndex | ||
edges | undefined | | ||
features | FeatureIndex | ||
fillFlags | FillFlags | ||
hasBakedLighting | undefined | boolean | ||
is2d | undefined | boolean | ||
isPlanar | undefined | boolean | ||
isVolumeClassifier | undefined | boolean | ||
material | undefined | RenderMaterial | ||
normals | undefined | OctEncodedNormal[] | ||
points | QPoint3dList | Omit<, "add"> | ||
textureMapping | undefined | { texture: RenderTexture, uvParams: Point2d[] } | ||
vertIndices | number[] |
Defined in
Last Updated: 20 June, 2023