NotificationHandler Class
Base class for all implementations of an Ipc notification response interface. This class is implemented on your frontend to supply methods to receive notifications from your backend.
Create a subclass to implement your Ipc response interface. Your class should be declared like this:
class MyNotificationHandler extends NotificationHandler implements MyNotifications
to ensure all method names and signatures are correct. Your methods cannot have a return value.
Then, call MyNotificationHandler.register
at startup to connect your class to your channel.
extensions
Extended by
Methods
Name | Description | |
---|---|---|
constructor(): NotificationHandler | ||
registerImpl(): RemoveFunction | ||
register(): RemoveFunction Static | Register this class as the handler for notifications on its channel. |
Properties
Name | Type | Description | |
---|---|---|---|
channelName Accessor AbstractReadOnly | string | All subclasses must implement this method to specify their response channel name. |
Defined in
- core/frontend/src/IpcApp.ts Line 167
Last Updated: 20 June, 2023