BriefcaseNotificationHandler Class
Base class for notification handlers for events from the backend that are specific to a BriefcaseConnection.
see BriefcaseTxns.
Extends
Extended by
Methods
Name | Description | |
---|---|---|
constructor(_key: string): BriefcaseNotificationHandler |
Inherited methods
Name | Inherited from | Description |
---|---|---|
registerImpl(): RemoveFunction | NotificationHandler | |
register(): RemoveFunction Static | NotificationHandler | Register this class as the handler for notifications on its channel. |
Properties
Name | Type | Description | |
---|---|---|---|
briefcaseChannelName Accessor AbstractReadOnly | string | ||
channelName Accessor ReadOnly | string |
Defined in
Last Updated: 20 June, 2023