MapLayerSource Class
A source for map layers. These may be catalogued for convenient use by users or applications.
Methods
Name | Description | |
---|---|---|
toJSON(): { formatId: string, name: string, transparentBackground: undefined | boolean, url: string } | ||
toLayerSettings(subLayers?: MapSubLayerProps[]): undefined | ImageMapLayerSettings | ||
validateSource(ignoreCache?: boolean): Promise<MapLayerSourceValidation> | ||
fromJSON(json: MapLayerSourceProps): undefined | MapLayerSource Static |
Properties
Name | Type | Description | |
---|---|---|---|
baseMap | boolean | ||
formatId | string | ||
name | string | ||
password | undefined | string | ||
transparentBackground | undefined | boolean | ||
url | string | ||
userName | undefined | string |
Defined in
Last Updated: 20 June, 2023