TentativePoint Class
extensions
Methods
Name | Description | |
---|---|---|
constructor(): TentativePoint | ||
clear(doErase: boolean): void | ||
decorate(context: DecorateContext): void | ||
getCurrSnap(): undefined | SnapDetail | ||
getHitAndList(holder: HitListHolder): undefined | SnapDetail | ||
getPoint(): Point3d | ||
onButtonEvent(ev: BeButtonEvent): void | ||
onInitialized(): void | ||
process(ev: BeButtonEvent): void | ||
removeTentative(): void | ||
setCurrSnap(newSnap?: SnapDetail): void | ||
setHitList(list?: HitList<HitDetail>): void | ||
setPoint(point: Point3d): void | ||
showTentative(): void |
Properties
Name | Type | Description | |
---|---|---|---|
currSnap | undefined | SnapDetail | ||
isActive | boolean | ||
isSnapped Accessor ReadOnly | boolean | ||
tpHits | undefined | HitList<HitDetail> | ||
viewport | undefined | ScreenViewport |
Defined in
Last Updated: 20 June, 2023