ElementPicker Class
extensions
Methods
Name | Description | |
---|---|---|
constructor(): ElementPicker | ||
doPick(vp: ScreenViewport, pickPointWorld: Point3d, pickRadiusView: number, options: LocateOptions): number | Generate a list of elements that are close to a given point. | |
empty(): void | ||
getHit(i: number): undefined | HitDetail | Return a hit from the list of hits created the last time pickElements was called. | |
getHitList(takeOwnership: boolean): HitList<HitDetail> | return the HitList for the last Pick performed. | |
getNextHit(): undefined | HitDetail | ||
resetCurrentHit(): void | ||
testHit(hit: HitDetail, vp: ScreenViewport, pickPointWorld: Point3d, pickRadiusView: number, options: LocateOptions): boolean |
Properties
Name | Type | Description | |
---|---|---|---|
hitList | undefined | HitList<HitDetail> | ||
pickPointWorld Readonly | Point3d | ||
viewport | undefined | Viewport |
Defined in
Last Updated: 20 June, 2023