Tiles Class
Provides access to TileTrees associated with an IModelConnection. The tile trees are accessed indirectly via their corresponding TileTreeOwners. Loaded tile trees will be discarded after the iModel is closed, after a period of disuse, or when the contents of a GeometricModelState they represent change.
see IModelConnection.tiles.
extensions
Implements
- Iterable<{ id: any, owner: TileTreeOwner, supplier: TileTreeSupplier }>
Methods
Name | Description | |
---|---|---|
[iterator](): Iterator<{ id: any, owner: TileTreeOwner, supplier: TileTreeSupplier }, any, undefined> | Iterate over all of the TileTreeOwners. | |
dropSupplier(supplier: TileTreeSupplier): void | Disposes of all TileTrees belonging to supplier and removes supplier from the set of known tile tree suppliers. |
|
forEachTreeOwner(func: (owner: TileTreeOwner) => void): void | Invokes a function on each extant TileTreeOwner. | |
getTileTreeOwner(id: any, supplier: TileTreeSupplier): TileTreeOwner | Obtain the owner of a TileTree. | |
getTreeOwnersForSupplier(supplier: TileTreeSupplier): Iterable<{ id: any, owner: TileTreeOwner }> | Obtain the TileTreeOwners supplied by the specified supplier. | |
updateForScheduleScript(scriptSourceElementId: string): Promise<void> | Update the Tiles for any TileTrees that use the RenderSchedule.Script hosted by the specified |
Defined in
- core/frontend/src/Tiles.ts Line 77
Last Updated: 20 June, 2023