clone Method
Create a copy of this MapLayerSettings, optionally modifying some of its properties.
clone(changedProps: Partial<ImageMapLayerProps>): ImageMapLayerSettings
Parameter | Type | Description |
---|---|---|
changedProps | Partial<ImageMapLayerProps> | JSON representation of the properties to change. |
Returns - ImageMapLayerSettings
A MapLayerSettings with all of its properties set to match those of this
, except those explicitly defined in changedProps
.
Defined in
- core/common/src/MapLayerSettings.ts Line 325
Last Updated: 20 June, 2023