fromJSON MethodStatic
Create a base layer from its JSON representation. TODO: This, MapLayerSettings.fromJSON, and MapSubLayerSettings.fromJSON should never return undefined. That means they should not accept undefined for props and should define props such that it fully describes the layer - e.g., url and name must be defined.
fromJSON(props: BaseMapLayerProps): BaseMapLayerSettings
Parameter | Type | Description |
---|---|---|
props | BaseMapLayerProps |
Returns - BaseMapLayerSettings
Defined in
- core/common/src/MapLayerSettings.ts Line 518
Last Updated: 20 June, 2023