cartographicToSpatialFromEcef Method
Convert a Cartographic to a point in this iModel's Spatial coordinates using its IModel.ecefLocation.
cartographicToSpatialFromEcef(cartographic: Cartographic, result?: Point3d): Point3d
throws IModelError if IModel.isGeoLocated is false.
note The resultant point will only be meaningful if the ECEF coordinate is close on the earth to the iModel.
Parameter | Type | Description |
---|---|---|
cartographic | Cartographic | A cartographic location |
result | Point3d | If defined, use this for output |
Returns - Point3d
A point in this iModel's spatial coordinates
Defined in
- core/common/src/IModel.ts Line 627
Last Updated: 20 June, 2023