QPoint3dBuffer.unquantizePoint Function
Extracts and unquantizes the point at the specified index from a buffer.
unquantizePoint(buffer: QPoint3dBuffer, pointIndex: number, result?: Point3d): Point3d
throws Error if pointIndex
is out of bounds.
Parameter | Type | Description |
---|---|---|
buffer | QPoint3dBuffer | The array of points and the quantization parameters. |
pointIndex | number | |
result | Point3d | If supplied, a preallocated Point3d to initialize with the result and return. |
Returns - Point3d
The point at pointIndex
.
Defined in
- core/common/src/QPoint.ts Line 686
Last Updated: 20 June, 2023