setSunTime Method
Adjust the solar light direction based on a date and time at a geographic location.
This replaces this.lights
with a copy that records the time point and the computed direction.
setSunTime(timePoint: number, location: IModel | Cartographic): void
see DisplayStyle3dSettings.sunTime to get the current sun time.
see DisplayStyle3dSettings.clearSunTime to clear the time point.
note If location
is an iModel lacking an EcefLocation, a location in Exton, Pennsylvania will be used to compute the light direction instead.
Parameter | Type | Description |
---|---|---|
timePoint | number | The time in UNIX milliseconds. |
location | IModel | Cartographic | The geographic location; or an iModel, in which case the iModel's EcefLocation is used. |
Returns - void
Defined in
- core/common/src/DisplayStyleSettings.ts Line 1312
Last Updated: 20 June, 2023