Uint32ArrayBuilder Class
A TypedArrayBuilder for producing a Uint32Array.
Extends
- TypedArrayBuilder<Uint32Array>
Methods
Name | Description | |
---|---|---|
constructor(options?: TypedArrayBuilderOptions): Uint32ArrayBuilder | See TypedArrayBuilder constructor. | |
toUint8Array(includeUnusedCapacity: boolean = false): Uint8Array | Obtain a view of the finished array as an array of bytes. |
Inherited methods
Name | Inherited from | Description |
---|---|---|
append(values: Uint32Array): void | TypedArrayBuilder<Uint32Array> | Append an array of values, resizing (at most once) if necessary. |
at(index: number): number | TypedArrayBuilder<Uint32Array> | Like TypedArray.at, |
ensureCapacity(newCapacity: number): number | TypedArrayBuilder<Uint32Array> | Ensure that TypedArrayBuilder.capacity is at least equal to newCapacity . |
push(value: number): void | TypedArrayBuilder<Uint32Array> | Append the specified value, resizing if necessary. |
toTypedArray(includeUnusedCapacity: boolean = false): Uint32Array | TypedArrayBuilder<Uint32Array> | Obtain the finished array. |
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
_constructor Protected | Constructor<Uint32Array> | TypedArrayBuilder<Uint32Array> | The constructor for the specific type of array being populated. |
_data Protected | Uint32Array | TypedArrayBuilder<Uint32Array> | The underlying typed array, to be reallocated and copied when its capacity is exceeded. |
_length Protected | number | TypedArrayBuilder<Uint32Array> | The number of elements added to the array so far. |
capacity Accessor ReadOnly | number | TypedArrayBuilder<Uint32Array> | The number of elements that can fit into the memory currently allocated for the array. |
growthFactor Readonly | number | TypedArrayBuilder<Uint32Array> | Multiplier applied to required capacity by TypedArrayBuilder.ensureCapacity. |
length Accessor ReadOnly | number | TypedArrayBuilder<Uint32Array> | The number of elements currently in the array. |
Defined in
Last Updated: 20 June, 2023