CloudSqlite.CloudContainer Interface
A CloudSqlite container that may be connected to a CloudCache.
Methods
Name | Description | |
---|---|---|
abandonChanges(): void | Abandon any local changes in this container. | |
acquireWriteLock(user: string): void | Attempt to acquire the write lock for this CloudContainer. | |
checkForChanges(): void | Poll cloud storage for changes from other processes. | |
cleanDeletedBlocks(nSeconds?: number): Promise<void> | Clean any unused deleted blocks from cloud storage. | |
clearWriteLock(): void | Destroy any currently valid write lock from this or any other process. | |
connect(cache: CloudSqlite.CloudCache): void | Connect this CloudContainer to a CloudCache for reading or writing its manifest, write lock, and databases. | |
copyDatabase(dbName: string, toAlias: string): Promise<void> | Create a copy of an existing database within this CloudContainer with a new name. | |
deleteDatabase(dbName: string): Promise<void> | Remove a database from this CloudContainer. | |
detach(): void | Permanently Detach and Disconnect this CloudContainer from its CloudCache. | |
disconnect(): void | Disconnect this CloudContainer from its CloudCache. | |
initializeContainer(opts?: { blockSize?: number, checksumBlockNames?: boolean }): void | initialize a cloud blob-store container to be used as a new Sqlite CloudContainer. | |
queryDatabase(dbName: string): undefined | CloudSqlite.CachedDbProps | Get the status of a specific database in this CloudContainer. | |
queryDatabaseHash(dbName: string): string | Get the SHA1 hash of the content of a database. | |
queryDatabases(globArg?: string): string[] | Get the list of database names in this CloudContainer. | |
releaseWriteLock(): void | Release the write lock if it is currently held. | |
uploadChanges(): Promise<void> | Upload any changed blocks from all databases in this CloudContainer. |
Properties
Name | Type | Description | |
---|---|---|---|
cache Readonly | undefined | CloudSqlite.CloudCache |
Defined in
- backend/src/CloudSqlite.ts Line 190
Last Updated: 20 June, 2023