CloudSqlite.CachedDbProps Interface
Returned from CloudContainer.queryDatabase
describing one database in the container
Properties
Name | Type | Description | |
---|---|---|---|
dirtyBlocks Readonly | number | the number of blocks from this database that have been modified in the CloudCache and need to be uploaded. | |
localBlocks Readonly | number | the number of blocks of the database that have been downloaded into the CloudCache | |
state Readonly | | "copied" | "deleted" | the state of this database. | |
totalBlocks Readonly | number | The total of (4Mb) blocks in the database. | |
transactions Readonly | boolean | If true, the database currently has transactions in the WAL file and may not be uploaded until they have been checkPointed. |
Defined in
- backend/src/CloudSqlite.ts Line 52
Last Updated: 20 June, 2023