ElementOwnsExternalSourceAspects Class
Relates an Element and an ExternalSourceAspect that it owns.
Extends
Methods
Name | Description | |
---|---|---|
constructor(elementId: string, relClassName: string = ElementOwnsExternalSourceAspects.classFullName): ElementOwnsExternalSourceAspects |
Inherited methods
Name | Inherited from | Description |
---|---|---|
toJSON(): RelatedElementProps | ElementOwnsMultiAspects | |
fromJSON(json?: RelatedElementProps): undefined | RelatedElement Static | ElementOwnsMultiAspects | |
idFromJson(json: any): string Static | ElementOwnsMultiAspects | Accept the value of a navigation property that might be in the shortened format of just an id or might be in the full RelatedElement format. |
Properties
Name | Type | Description | |
---|---|---|---|
classFullName Static | string |
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
id Readonly | string | ElementOwnsMultiAspects | The Id of the element to which this element is related. |
none StaticReadonly | RelatedElement | ElementOwnsMultiAspects | Used to null out an existing navigation relationship. |
relClassName Readonly | undefined | string | ElementOwnsMultiAspects | The full className of the relationship class. |
Defined in
Last Updated: 20 June, 2023