UpdateModelOptions Interface
Options for IModelDb.Models.updateModel
note To mark only the geometry as changed, use IModelDb.Models.updateGeometryGuid instead.
Extends
Properties
Name | Type | Description | |
---|---|---|---|
geometryChanged | undefined | boolean | If defined, update the GeometryGuid of the Model | |
updateLastMod | undefined | boolean | If defined, update the last modify time of the Model |
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
classFullName | string | ModelProps | The full name of the ECClass for this entity, in the form "Schema:ClassName" |
id | undefined | string | ModelProps | The Id of the entity. |
isInstanceOfEntity Readonly | undefined | undefined | ModelProps | A non-existent property used to discriminate between EntityProps and Entity. |
isPrivate | undefined | boolean | ModelProps | |
isTemplate | undefined | boolean | ModelProps | |
jsonProperties | undefined | any | ModelProps | |
modeledElement | RelatedElementProps | ModelProps | |
name | undefined | string | ModelProps | |
parentModel | undefined | string | ModelProps |
Defined in
- backend/src/IModelDb.ts Line 64
Last Updated: 20 June, 2023