queryEntityIds Method
Query for a set of entity ids, given an EntityQueryParams
queryEntityIds(params: EntityQueryParams): Id64Set
throws IModelError if the generated statement is invalid or IModelDb.maxLimit exceeded when collecting ids.
Example:
// If you are sure that the name of the PhysicalPartition is unique within the
// iModel or if you have some way of filtering results, you could do a direct query
// for just its code value using the IModelDb.queryEntityIds convenience method.
for (const eidStr of iModel.queryEntityIds({ from: PhysicalPartition.classFullName, where: "CodeValue=:cv", bindings: { cv: "Physical" } })) {
assert.equal(iModel.elements.getElement(eidStr).code.value, "Physical");
}
Parameter | Type | Description |
---|---|---|
params | EntityQueryParams | The query parameters. The limit and offset members should be used to page results. |
Returns - Id64Set
an Id64Set with results of query
Defined in
- backend/src/IModelDb.ts Line 674
Last Updated: 20 June, 2023