importSchemas Method
Import an ECSchema. On success, the schema definition is stored in the iModel. This method is asynchronous (must be awaited) because, in the case where this IModelDb is a briefcase, this method first obtains the schema lock from the iModel server. You must import a schema into an iModel before you can insert instances of the classes in that schema. See Element
importSchemas(schemaFileNames: string[], options?: SchemaImportOptions): Promise<void>
throws IModelError if the schema lock cannot be obtained or there is a problem importing the schema.
note Changes are saved if importSchemas is successful and abandoned if not successful.
see IModelDb.querySchemaVersion
Parameter | Type | Description |
---|---|---|
schemaFileNames | string[] | |
options | SchemaImportOptions | options during schema import. |
Returns - Promise<void>
Defined in
- backend/src/IModelDb.ts Line 811
Last Updated: 20 June, 2023