IModelDb.Views Class
The collection of views in an IModelDb.
Methods
Name | Description | |
---|---|---|
getThumbnail(viewDefinitionId: string): undefined | ThumbnailProps | Get the thumbnail for a view. | |
getViewStateData(viewDefinitionId: string, options?: ViewStateLoadProps): ViewStateProps | Deprecated | |
getViewStateProps(viewDefinitionId: string, options?: ViewStateLoadProps): Promise<ViewStateProps> | Obtain a ViewStateProps for a ViewDefinition specified by element Id. | |
iterateViews(params: ViewQueryParams, callback: (view: ViewDefinition) => boolean): boolean | Iterate all ViewDefinitions matching the supplied query. | |
queryViewDefinitionProps(className: string = "BisCore.ViewDefinition", limit: number = IModelDb.defaultLimit, offset: number = 0, wantPrivate: boolean = false): ViewDefinitionProps[] | Query for the array of ViewDefinitionProps of the specified class and matching the specified IsPrivate setting. | |
saveThumbnail(viewDefinitionId: string, thumbnail: ThumbnailProps): number | Save a thumbnail for a view. | |
setDefaultViewId(viewId: string): void | Set the default view property the iModel |
Properties
Name | Type | Description | |
---|---|---|---|
defaultQueryParams StaticReadonly | ViewQueryParams | Default parameters for iterating/querying ViewDefinitions. |
Defined in
- backend/src/IModelDb.ts Line 2012
Last Updated: 20 June, 2023