getAspects Method
Get the ElementAspect instances that are owned by the specified element.
getAspects(elementId: string, aspectClassFullName?: string): ElementAspect[]
throws IModelError
Parameter | Type | Description |
---|---|---|
elementId | string | Get ElementAspects associated with this Element |
aspectClassFullName | string | Optionally filter ElementAspects polymorphically by this class name |
Returns - ElementAspect[]
Defined in
- backend/src/IModelDb.ts Line 1956
Last Updated: 20 June, 2023