createQueryReader Method
Beta
Allow to execute query and read results along with meta data. The result are streamed.
createQueryReader(ecsql: string, params?: QueryBinder, config?: QueryOptions): ECSqlReader
Parameter | Type | Description |
---|---|---|
ecsql | string | |
params | QueryBinder | The values to bind to the parameters (if the ECSQL has any). |
config | QueryOptions | Allow to specify certain flags which control how query is executed. |
Returns - ECSqlReader
Returns an ECSqlReader which helps iterate over the result set and also give access to metadata.
Defined in
- backend/src/IModelDb.ts Line 493
Last Updated: 20 June, 2023