ExportPartInstanceInfo Interface
Information about references to GeometryPart elements found during a call to IModelDb.exportGraphics. See IModelDb.exportPartGraphics for the intended use case.
Properties
Name | Type | Description | |
---|---|---|---|
displayProps | ExportPartDisplayInfo | The base display properties when the GeometryPart was referenced. | |
partId | string | ID for the GeometryPart | |
partInstanceId | string | ID for the element that contained the reference to the GeometryPart | |
transform | undefined | Float64Array | A row-major storage 4x3 transform for this instance. |
Defined in
- backend/src/ExportGraphics.ts Line 108
Last Updated: 20 June, 2023