ExportPartDisplayInfo Interface
Information about the base display properties when a GeometryPart was referenced. This is intended to be used with IModelDb.exportPartGraphics.
- If two ExportPartInstanceInfo have the same ExportPartDisplayInfos, they will result in the same graphics (with a different transform).
- If two ExportPartInstanceInfo have different ExportPartDisplayInfos, they may result in different graphics.
Properties
Name | Type | Description | |
---|---|---|---|
categoryId | string | ||
elmTransparency | number | ||
geometryClass | GeometryClass | ||
lineColor | number | ||
materialId | string | ||
subCategoryId | string |
Defined in
- backend/src/ExportGraphics.ts Line 94
Last Updated: 20 June, 2023