exportPartGraphics Method
Exports meshes suitable for graphics APIs from a specified GeometryPart in this IModelDb. The expected use case is to call IModelDb.exportGraphics and supply the optional partInstanceArray argument, then call this function for each unique GeometryPart from that list.
- The results of changing ExportPartGraphicsOptions during the ExportPartGraphicsOptions.onPartGraphics callback are not defined.
- See export-gltf under test-apps in the iTwin.js monorepo for a working reference.
exportPartGraphics(exportProps: ExportPartGraphicsOptions): DbResult
Parameter | Type | Description |
---|---|---|
exportProps | ExportPartGraphicsOptions |
Returns - DbResult
0 is successful, status otherwise
Defined in
- backend/src/IModelDb.ts Line 1252
Last Updated: 20 June, 2023