IModelHostConfiguration Class
Configuration of core-backend.
Implements
Methods
Name | Description | |
---|---|---|
constructor(): IModelHostConfiguration |
Properties
Name | Type | Description | |
---|---|---|---|
appAssetsDir | undefined | string | The directory where application assets are found. | |
authorizationClient | undefined | AuthorizationClient | The AuthorizationClient used to obtain AccessTokens. | |
cacheDir | undefined | string | Root of the directory holding all the files that iTwin.js caches | |
compressCachedTiles | undefined | boolean | Whether to compress cached tiles. | |
defaultLogTileLoadTimeThreshold Static | number | ||
defaultLogTileSizeThreshold Static | number | ||
defaultTileRequestTimeout Static | number | ||
hubAccess | undefined | BackendHubAccess | Beta | |
restrictTileUrlsByClientIp | undefined | boolean | Beta | |
tileCacheAzureCredentials | undefined | AzureBlobStorageCredentials | Beta | |
tileCacheService | undefined | CloudStorageService | Beta | |
workspace | undefined | WorkspaceOpts | Beta |
Defined in
- backend/src/IModelHost.ts Line 186
Last Updated: 20 June, 2023