IModelHostOptions Interface
Options for IModelHost.startup
Implemented by
Properties
Name | Type | Description | |
---|---|---|---|
appAssetsDir | undefined | string | The directory where application assets are found. | |
authorizationClient | undefined | AuthorizationClient | The AuthorizationClient used to obtain AccessTokens. | |
cacheDir | undefined | string | Root of the directory holding all the files that iTwin.js caches | |
compressCachedTiles | undefined | boolean | Whether to compress cached tiles. | |
crashReportingConfig | undefined | | Crash-reporting configuration | |
enableOpenTelemetry | undefined | boolean | Whether to enable OpenTelemetry tracing | Beta |
hubAccess | undefined | BackendHubAccess | The kind of iModel hub server to use. | Beta |
maxTileCacheDbSize | undefined | number | The maximum size in bytes to which a local sqlite database used for caching tiles can grow before it is purged of least-recently-used tiles. | Beta |
restrictTileUrlsByClientIp | undefined | boolean | Whether to restrict tile cache URLs by client IP address (if available). | Beta |
tileCacheAzureCredentials | undefined | AzureBlobStorageCredentials | The Azure blob storage credentials to use for the tile cache service. | Beta |
tileCacheService | undefined | CloudStorageService | Deprecated Beta | |
tileCacheStorage | undefined | ServerStorage | Beta | |
workspace | undefined | WorkspaceOpts | Options for creating the Workspace | Beta |
Defined in
- backend/src/IModelHost.ts Line 81
Last Updated: 20 June, 2023