insert MethodStatic
Insert a new RenderMaterial into a model.
insert(iModelDb: IModelDb, definitionModelId: string, materialName: string, params: RenderMaterialElementParams): string
throws IModelError if unable to insert the element.
Parameter | Type | Description |
---|---|---|
iModelDb | IModelDb | Insert into this iModel |
definitionModelId | string | Insert the new Texture into this DefinitionModel |
materialName | string | The name/CodeValue of the RenderMaterial |
params | RenderMaterialElementParams | Parameters object which describes how to construct the RenderMaterial |
Returns - string
The Id of the newly inserted RenderMaterial element.
Defined in
- backend/src/Material.ts Line 178
Last Updated: 20 June, 2023