create MethodStatic
Create a RenderMaterial with given parameters.
create(iModelDb: IModelDb, definitionModelId: string, materialName: string, params: RenderMaterialElementParams): RenderMaterialElement
throws IModelError if unable to create the element.
Parameter | Type | Description |
---|---|---|
iModelDb | IModelDb | The iModel |
definitionModelId | string | The DefinitionModel |
materialName | string | The name/CodeValue of the RenderMaterial |
params | RenderMaterialElementParams | Parameters object which describes how to construct the RenderMaterial |
Returns - RenderMaterialElement
The newly constructed RenderMaterial element.
Defined in
- backend/src/Material.ts Line 94
Last Updated: 20 June, 2023