ECSqlValue Class
Value of a column in a row of an ECSQL query result.
See also:
Methods
Name | Description | |
---|---|---|
getArray(): any[] | Get this array value as JavaScript array | |
getArrayIterator(): ECSqlValueIterator | Get an iterator for iterating the array elements of this array value. | |
getBlob(): Uint8Array | Get the value as BLOB | |
getBoolean(): boolean | Get the value as a boolean value | |
getClassNameForClassId(): string | Get the ClassId value formatted as fully qualified class name. | |
getDateTime(): string | Get the value as a DateTime value (formatted as ISO8601 string) | |
getDouble(): number | Get the value as a double value | |
getEnum(): undefined | ECEnumValue[] | Get the value as ECEnumeration value | |
getGeometry(): any | Get the value as a IGeometry value (as ECJSON IGeometry) | |
getGuid(): string | Get the value as a GUID (formatted as GUID string). | |
getId(): string | Get the value as a Id (formatted as hexadecimal string). | |
getInteger(): number | Get the value as a integer value | |
getNavigation(): NavigationValue | Get the value as NavigationValue | |
getString(): string | Get the value as a string value | |
getStruct(): any | Get this struct value's content as object literal | |
getStructIterator(): ECSqlValueIterator | Get an iterator for iterating the struct members of this struct value. | |
getXAndY(): Readonly<WritableXAndY> | Get the value as XAndY | |
getXYAndZ(): Readonly<WritableXYAndZ> | Get the value as XYAndZ |
Properties
Name | Type | Description | |
---|---|---|---|
columnInfo Accessor ReadOnly | ECSqlColumnInfo | Get information about the query result's column this value refers to. | |
isNull Accessor ReadOnly | boolean | Indicates whether the value is NULL or not. | |
value Accessor ReadOnly | any | Get the value of this ECSQL value |
Defined in
- backend/src/ECSqlStatement.ts Line 586
Last Updated: 20 June, 2023