ECSqlColumnInfo Interface
Information about an ECSQL column in an ECSQL query result. See ECSqlValue.columnInfo, ECSqlStatement.getValue, ECSqlStatement
Methods
Name | Description | |
---|---|---|
getAccessString(): string | Gets the full access string to the corresponding ECSqlValue starting from the root class. | |
getOriginPropertyName(): undefined | string | Gets the name of the original property that the column data is from. | |
getPropertyName(): string | Gets the name of the property backing the column. | |
getRootClassAlias(): string | Gets the class alias of the root class to which the column refers to. | |
getRootClassName(): string | Gets the fully qualified name of the ECClass of the top-level ECProperty backing this column. | |
getRootClassTableSpace(): string | Gets the table space in which this root class is persisted. | |
getType(): ECSqlValueType | Gets the data type of the column. | |
isEnum(): boolean | Indicates whether the column refers to an ECEnumeration property. | |
isGeneratedProperty(): boolean | Indicates whether the column is backed by a generated property or not. | |
isSystemProperty(): boolean | Indicates whether the column refers to a system property (e.g. |
Defined in
- backend/src/ECSqlStatement.ts Line 681
Last Updated: 20 June, 2023